summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-22 22:56:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-02-22 23:39:31 +0200
commitf13ddb46b5d32a6f6a6f83562e268fbbcaf74ef3 (patch)
tree4c3582b9bcf64688bad99785a0c911062e926867 /gnu/packages
parent16e151a69ac714a0ca407966d42ec4b015ec3cd5 (diff)
gnu: rust-byteorder-1.3: Upgrade to 1.3.4.
* gnu/packages/crates-io.scm (rust-byteorder-1.3): Upgrade to 1.3.4. [arguments]: Don't skip build. Replace rust-rand-0.4 with 0.6 in cargo-development-inputs.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f64aa74390..4f2687060e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1317,7 +1317,7 @@ in a byte slice, fast.")
(define-public rust-byteorder-1.3
(package
(name "rust-byteorder")
- (version "1.3.2")
+ (version "1.3.4")
(source
(origin
(method url-fetch)
@@ -1326,14 +1326,13 @@ in a byte slice, fast.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1xbwjlmq2ziqjmjvkqxdx1yh136xxhilxd40bky1w4d7hn4xvhx7"))))
+ "1pkjfhgjnq898g1d38ygcfi0msg3m6756cwv0sgysj1d26p8mi08"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-development-inputs
+ `(#:cargo-development-inputs
(("rust-doc-comment" ,rust-doc-comment-0.3)
("rust-quickcheck" ,rust-quickcheck-0.8)
- ("rust-rand" ,rust-rand-0.4))))
+ ("rust-rand" ,rust-rand-0.6))))
(home-page
"https://github.com/BurntSushi/byteorder")
(synopsis