summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPkill -9 <pkill9@runbox.com>2019-02-19 07:46:29 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-05 23:18:16 -0400
commitf8f096d1e8f930ebeecd98125b9c03d97b3c7f65 (patch)
tree8d3c7c9f628d2ff9082294a2873e74a514581238 /gnu/packages
parent362a1cc3fb50c67ed4249b97827dbffdbdace766 (diff)
gnu: Add tetrinet.
* gnu/packages/games.scm (tetrinet): New variable. Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2e1aed1ee8..f34f3a9ca5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -63,6 +63,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
+;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -552,6 +553,47 @@ Playing bastet can be a painful experience, especially if you usually make
canyons and wait for the long I-shaped block to clear four rows at a time.")
(license license:gpl3+)))
+(define-public tetrinet
+ (package
+ (name "tetrinet")
+ (version "0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://tetrinet.or.cz/download/tetrinet-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "0b4pddqz6is1771qmvcj8qqlr4in2djdbkk13agvp9yhfah2v8x7"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (arguments
+ `(#:tests? #f ;no tests
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (add-after 'unpack 'fix-install-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ (substitute* "Makefile"
+ (("/usr/games") (string-append out "/bin"))))))
+ (add-after 'install 'install-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (for-each (lambda (file)
+ (install-file file doc))
+ (list "README" "tetrinet.txt"))))))))
+ (home-page "http://tetrinet.or.cz")
+ (synopsis "Terminal-based multiplayer Tetris clone")
+ (description "Tetrinet is a multiplayer Tetris-like game with powerups and
+attacks you can use on opponents.")
+ (license license:public-domain)))
+
(define-public vitetris
(package
(name "vitetris")