summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-07-30 17:19:34 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-31 01:03:24 +0200
commitfa2d94b5e362c684da812d494463d965e601c18d (patch)
treec1d65cd1497bf947a3d83a064539266e62d06723 /gnu/packages
parent2b55f914c3198f9b07399d10502fbdb22b7d6e47 (diff)
gnu: python-onnx: Rename to "onnx".
* gnu/packages/machine-learning.scm (python-onnx): Rename to... (onnx): ... this, and change 'name' field accordingly. (python-onnx): New variable. * gnu/packages/patches/python-onnx-shared-libraries.patch: Rename to... * gnu/packages/patches/onnx-shared-libraries.patch: ... this. * gnu/packages/patches/python-onnx-use-system-googletest.patch: Rename to... * gnu/packages/patches/onnx-use-system-googletest.patch: ... this. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/machine-learning.scm14
-rw-r--r--gnu/packages/patches/onnx-shared-libraries.patch (renamed from gnu/packages/patches/python-onnx-shared-libraries.patch)0
-rw-r--r--gnu/packages/patches/onnx-use-system-googletest.patch (renamed from gnu/packages/patches/python-onnx-use-system-googletest.patch)0
3 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 1cea91977f..75faeb8eb8 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -581,16 +581,16 @@ tools. This enables both rapid prototyping of data pipelines and extensibility
in terms of new algorithms.")
(license license:gpl3+)))
-(define-public python-onnx
+(define-public onnx
(package
- (name "python-onnx")
+ (name "onnx")
(version "1.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "onnx" version))
- (patches (search-patches "python-onnx-use-system-googletest.patch"
- "python-onnx-shared-libraries.patch"))
+ (patches (search-patches "onnx-use-system-googletest.patch"
+ "onnx-shared-libraries.patch"))
(sha256
(base32 "0yjv2axz2vc2ysniwislsp53fsb8f61y1warrr2ppn2d9ijml1d9"))
(modules '((guix build utils)))
@@ -658,6 +658,12 @@ computation graph model, as well as definitions of built-in operators and
standard data types.")
(license license:expat)))
+(define-public python-onnx
+ ;; This used to be called "python-onnx" because it provided nothing but
+ ;; Python bindings. The package now provides shared libraries and C++
+ ;; headers, hence the name change.
+ (deprecated-package "python-onnx" onnx))
+
(define-public rxcpp
(package
(name "rxcpp")
diff --git a/gnu/packages/patches/python-onnx-shared-libraries.patch b/gnu/packages/patches/onnx-shared-libraries.patch
index 00583b35da..00583b35da 100644
--- a/gnu/packages/patches/python-onnx-shared-libraries.patch
+++ b/gnu/packages/patches/onnx-shared-libraries.patch
diff --git a/gnu/packages/patches/python-onnx-use-system-googletest.patch b/gnu/packages/patches/onnx-use-system-googletest.patch
index 5dfcbc6dc3..5dfcbc6dc3 100644
--- a/gnu/packages/patches/python-onnx-use-system-googletest.patch
+++ b/gnu/packages/patches/onnx-use-system-googletest.patch