summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:34:46 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commitfc3d355df7d67201d1486ea1f86fa0121804f7af (patch)
treef150481ae70d0d922cfe283040abfef67a2b2604 /gnu/packages
parentbbf311e048afc38489346ab74c64d86e68bb5992 (diff)
gnu: kde-frameworks: Add bluez-qt.
* gnu/packages/kde-frameworks.scm (bluez-qt): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 85d000bb2d..97114cf783 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -25,6 +25,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt)
#:use-module (gnu packages xorg))
@@ -105,6 +106,40 @@ The REST API is defined here:
http://freedesktop.org/wiki/Specifications/open-collaboration-services/")
(license (list license:lgpl2.1+ license:lgpl3+))))
+(define-public bluez-qt
+ (package
+ (name "bluez-qt")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0gy0m7lcwwklf021l5i3v7j0cl7qz7cgvzrwpj87ix3kyw5xs80z"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("dbus" ,dbus)
+ ("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (arguments
+ `(#:configure-flags
+ '("-DINSTALL_UDEV_RULE:BOOL=OFF")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* _
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (zero? (system* "dbus-launch" "ctest" ".")))))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "QML wrapper for BlueZ")
+ (description "bluez-qt is a Qt-style library for accessing the bluez
+Bluetooth stack. It is used by the KDE Bluetooth stack, BlueDevil.")
+ (license (list license:lgpl2.1+ license:lgpl3+))))
+
(define-public kwindowsystem
(package
(name "kwindowsystem")