summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:58:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:26 +0200
commitfd128f8c5af4af0fa6bc9da7bb69138678f648ee (patch)
tree47cb6d3dacda52cdf7458d6ae94c2b74a6c26715 /gnu/packages
parent92d75955a3ee4337ae9726fada2c377a680c8b8c (diff)
gnu: Add texlive-luaquotes.
* gnu/packages/tex.scm (texlive-luaquotes): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b2c6c7cd2c..0c92ce95a8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16783,6 +16783,25 @@ to load external Lua modules, including modules installed via LuaRocks.")
cells using LaTeX macros.")
(license license:expat)))
+(define-public texlive-luaquotes
+ (package
+ (name "texlive-luaquotes")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/luaquotes/"
+ "tex/lualatex/luaquotes/")
+ (base32
+ "0lla3bd5prh5ld1p88f8c3mfck6c6jn241fq1fzz0a9vdhfsbpv0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luaquotes")
+ (synopsis "Smart setting of quotation marks")
+ (description
+ "This package automatically generates quotation marks and punctuation
+depending on the selected language.")
+ (license (list license:lppl1.3c license:cc-by-sa3.0))))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")