summaryrefslogtreecommitdiff
path: root/gnu/system/vm.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-12-05 12:59:15 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2017-12-15 11:52:38 +0100
commite22482038611a53a9d2b25df20363664cd91be2e (patch)
treeda53181cdbbe40b8035fdc577b0767e8055c9681 /gnu/system/vm.scm
parentacf54bca225b63f5b06e335a55045421c47bbd09 (diff)
bootloader: Factorize write-file-on-device.
* gnu/bootloader/extlinux.scm (install-extlinux): Factorize bootloader writing in a new procedure write-file-on-device defined in (gnu build bootloader). * gnu/build/bootloader.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new file. * gnu/system/vm.scm (qemu-img): Adapt to import and use (gnu build bootloader) module during derivation building. * gnu/scripts/system.scm (bootloader-installer-derivation): Ditto.
Diffstat (limited to 'gnu/system/vm.scm')
-rw-r--r--gnu/system/vm.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index b376337c8d..6102d465b8 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -277,10 +277,12 @@ register INPUTS in the store database of the image so that Guix can be used in
the image."
(expression->derivation-in-linux-vm
name
- (with-imported-modules (source-module-closure '((gnu build vm)
+ (with-imported-modules (source-module-closure '((gnu build bootloader)
+ (gnu build vm)
(guix build utils)))
#~(begin
- (use-modules (gnu build vm)
+ (use-modules (gnu build bootloader)
+ (gnu build vm)
(guix build utils)
(srfi srfi-26)
(ice-9 binary-ports))