summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-06-28 00:42:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-27 15:57:30 +0200
commit01944e0eb8a988a4ff26b93e95b3c04ca6935b14 (patch)
tree126de3afbb6706378739d0cfbcf3c465e6b4f025 /gnu
parentfe2be9c0cf4d4327f8ef9eda1668de76cbc4fca7 (diff)
gnu: Add r-banocc.
* gnu/packages/bioconductor.scm (r-banocc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c8a15c5123..c7d759d15b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2536,6 +2536,34 @@ Carlo) techniques and a DTU test is performed via a multivariate Wald test on
the posterior densities for the average relative abundance of transcripts.")
(license license:gpl3+)))
+(define-public r-banocc
+ (package
+ (name "r-banocc")
+ (version "1.20.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "banocc" version))
+ (sha256
+ (base32
+ "10vaggq1w5jkxd8r2k1mhymzvb7x3h8afwn2pvmcpj022ka7xhbx"))))
+ (properties `((upstream-name . "banocc")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-coda
+ r-mvtnorm
+ r-rstan
+ r-stringr))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/banocc")
+ (synopsis "Bayesian analysis of compositional covariance")
+ (description
+ "BAnOCC is a package designed for compositional data, where each sample
+sums to one. It infers the approximate covariance of the unconstrained data
+using a Bayesian model coded with @code{rstan}. It provides as output the
+@code{stanfit} object as well as posterior median and credible interval
+estimates for each correlation element.")
+ (license license:expat)))
+
(define-public r-biocversion
(package
(name "r-biocversion")