summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-15 15:39:33 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-27 22:51:59 +0000
commit028cd76fb3975e141640e522ea23f1daa50f7b89 (patch)
tree821f62268a27a751426c549df11dc58e636a34bb /gnu
parent2d3a898d89fe172283f94a55d502330f85b50e6e (diff)
gnu: python-poppy: Speed up tests.
* gnu/packages/astronomy.scm (python-poppy): Speed up tests. [arguments] <#:test-flags>: Add with "-n" option. [native-inputs]: Add python-pytest-xdist and python-scikit-image. Change-Id: Ic72b1c7c700204cc91e00dcc5a0706859420109b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 111599f442..0a2599590a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2354,6 +2354,10 @@ Low-Earth Orbit (LEO).")
(base32
"0s8rb61q8dz66s8d3qg44kb6bb5gi40zl41ik9wyccgb4kyf3brp"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-n" "auto")))
(propagated-inputs
;; XXX: With python-synphot (marked as optional) package added to the list
;; it tries to download from remote host during tests and fails. Overall
@@ -2368,8 +2372,10 @@ Low-Earth Orbit (LEO).")
python-pandas
python-pytest
python-pytest-astropy
- python-sphinx
- python-setuptools-scm))
+ python-pytest-xdist
+ python-scikit-image
+ python-setuptools-scm
+ python-sphinx))
(home-page "https://poppy-optics.readthedocs.io/")
(synopsis "Physical Optics Propagation in Python")
(description