summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 15:58:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:08 +0200
commit0561616a3208aa17fe5b1f9c425c44fe00218b08 (patch)
treeac978048eb9f6f37545d7ee15cd89a198fd63058 /gnu
parente6a2dbd35b3547220c21cce1da597fff3242d52a (diff)
gnu: Add texlive-collection-xetex.
* gnu/packages/tex.scm (texlive-collection-xetex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a23c996d43..c67c037700 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14613,6 +14613,63 @@ LaTeX which have widespread use.")
with packages in @code{collection-basic}.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-collection-xetex
+ (package
+ (name "texlive-collection-xetex")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-arabxetex
+ texlive-awesomebox
+ texlive-bidi-atbegshi
+ texlive-bidicontour
+ texlive-bidipagegrid
+ texlive-bidipresentation
+ texlive-bidishadowtext
+ texlive-businesscard-qrcode
+ texlive-collection-basic
+ texlive-cqubeamer
+ texlive-fixlatvian
+ texlive-font-change-xetex
+ texlive-fontbook
+ texlive-fontwrap
+ texlive-interchar
+ texlive-na-position
+ texlive-philokalia
+ texlive-ptext
+ texlive-realscripts
+ texlive-simple-resume-cv
+ texlive-simple-thesis-dissertation
+ texlive-tetragonos
+ texlive-ucharclasses
+ texlive-unicode-bidi
+ texlive-unimath-plain-xetex
+ texlive-unisugar
+ texlive-xebaposter
+ texlive-xechangebar
+ texlive-xecolor
+ texlive-xecyr
+ texlive-xeindex
+ texlive-xesearch
+ texlive-xespotcolor
+ texlive-xetex
+ texlive-xetex-itrans
+ texlive-xetex-pstricks
+ texlive-xetex-tibetan
+ texlive-xetexconfig
+ texlive-xetexfontinfo
+ texlive-xetexko
+ texlive-xevlna
+ texlive-zbmath-review-template))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "XeTeX and packages")
+ (description
+ "This collection includes packages for XeTeX, the Unicode and
+OpenType-enabled TeX by Jonathan Kew.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-grfext
(package
(name "texlive-grfext")