summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-04-26 09:26:44 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2021-04-26 09:26:44 +0200
commit0581cd81109855d00a3ffec1df33bdd99881d772 (patch)
treea41e383469e34c3563b43bd9b85bb12eb02b064a /gnu
parentd904abe0768293b2322dbf355b6e41d94e769d78 (diff)
gnu: Add simple-rgb.
* gnu/packages/lisp-xyz.scm (cl-simple-rgb, ecl-simple-rgb, sbcl-simple-rgb): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1d9d53c3e4..efb25f9678 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16102,3 +16102,33 @@ handling the accessing of files on the underlying system however.")
(define-public cl-terrable
(sbcl-package->cl-source-package sbcl-terrable))
+
+(define-public sbcl-simple-rgb
+ (let ((commit "ba9b0689362c28aa6a91c0636796c6c372657293")
+ (revision "1"))
+ (package
+ (name "sbcl-simple-rgb")
+ (version (git-version "0.01" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wmannis/simple-rgb/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ggv0h2n4mvwnggjr1b40gw667gnyykzki2zadaczi38ydzyzlp1"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/wmannis/simple-rgb")
+ (synopsis "Manipulate colors in RGB format")
+ (description
+ "This Common Lisp library focuses on the small set of basic color
+manipulations (lightening, compliments, etc.) you might use to generate a
+color palette for a GUI or web page.")
+ (license license:bsd-2))))
+
+(define-public ecl-simple-rgb
+ (sbcl-package->ecl-package sbcl-simple-rgb))
+
+(define-public cl-simple-rgb
+ (sbcl-package->cl-source-package sbcl-simple-rgb))