summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-01-24 18:51:44 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-01-25 09:32:31 +0100
commit064a7ea6e00119d6c157f3d07df5928af7fdac53 (patch)
tree83639a182b3e830afcf76bf85b4b6060485b8ff1 /gnu
parent547bd6921a01cea1c43488525dfa9f82089fce30 (diff)
gnu: sbcl-uax-15: Update to 0.1.1.
* gnu/packages/lisp-xyz.scm (sbcl-uax-15): Update to 0.1.1. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm54
1 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 9202882307..68c07002e3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -460,33 +460,33 @@ compatible with ANSI-compliant Common Lisp implementations.")
(sbcl-package->ecl-package sbcl-cl-ppcre))
(define-public sbcl-uax-15
- (let ((commit "e7439a91b72f533fcf736643e3ff0677b56c2e7d")
- (revision "1"))
- (package
- (name "sbcl-uax-15")
- (version (git-version "0.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sabracrolleton/uax-15")
- (commit commit)))
- (file-name (git-file-name "uax-15" version))
- (sha256
- (base32 "1vf8a2aikgx0l5bsq0z9s0dw3sgx1887xhagdlf66fwffa5jskg6"))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- `(("fiveam" ,sbcl-fiveam)))
- (inputs
- `(("cl-ppcre" ,sbcl-cl-ppcre)
- ("split-sequence" ,sbcl-split-sequence)))
- (arguments
- `(#:asd-systems '("uax-15")))
- (home-page "https://github.com/sabracrolleton/uax-15")
- (synopsis "Common Lisp implementation of unicode normalization functions")
- (description "This package provides supports for unicode normalization,
-RFC8264 and RFC7564.")
- (license license:expat))))
+ (package
+ (name "sbcl-uax-15")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sabracrolleton/uax-15")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "uax-15" version))
+ (sha256
+ (base32 "0p2ckw7mzxhwa9vbwj2q2dzayz9dl94d9yqd2ynp0pc5v8i0n2fr"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-systems
+ '("uax-15")))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (inputs
+ `(("cl-ppcre" ,sbcl-cl-ppcre)
+ ("split-sequence" ,sbcl-split-sequence)))
+ (home-page "https://github.com/sabracrolleton/uax-15")
+ (synopsis "Common Lisp implementation of unicode normalization functions")
+ (description
+ "This package provides supports for unicode normalization, RFC8264 and
+RFC7564.")
+ (license license:expat)))
(define-public cl-uax-15
(sbcl-package->cl-source-package sbcl-uax-15))