summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-10-23 23:21:12 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-10-24 14:39:43 +0300
commit069a5577e55540d61ba95c22a262e592bacd64b9 (patch)
tree3c133e6091058a610874c0e0034d7b2845044f11 /gnu
parent2f0e11127f7af9e3acca8dc30389207732d59947 (diff)
gnu: Add rust-pretty-hex-0.3.
* gnu/packages/crates-io.scm (rust-pretty-hex-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: Ic599aef2b1506574ad6b098894c22a6467aebc1a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2a42b25d8b..44deebc06f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -52506,6 +52506,25 @@ replacements, adding colorful diffs.")
"This package provides a minimal `syn` syntax tree pretty-printer.")
(license (list license:expat license:asl2.0))))
+(define-public rust-pretty-hex-0.3
+ (package
+ (name "rust-pretty-hex")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pretty-hex" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1mf8xvlfri4impj2paj4azx7hxh7l0i38cjyib1hiikwvlqhiyn6"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:cargo-development-inputs `(("rust-heapless" ,rust-heapless-0.5))))
+ (home-page "https://github.com/wolandr/pretty-hex")
+ (synopsis "Prettified output of hexadecimal byte slices")
+ (description "Pretty hex dump of byte slices in the common style.")
+ (license license:expat)))
+
(define-public rust-prettytable-rs-0.8
(package
(name "rust-prettytable-rs")