summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-07 21:12:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-08 10:37:08 +0200
commit0836c0769d46a45955600ed42dbdd36a4ce298bb (patch)
tree4f138e10b569fa54a5f87c9c416c39ad3c0dd4ef /gnu
parentd8dcd1200a9ce5cfb2333b7f43a72c40f8fc80bb (diff)
gnu: Add python-confection.
* gnu/packages/python-xyz.scm (python-confection): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a6c2cfbb73..cb323b5279 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15411,6 +15411,27 @@ provide an easy to use, pythonic and comprehensive Python interface to dialog.
This allows one to make simple text-mode user interfaces on Unix-like systems")
(license license:lgpl2.1)))
+(define-public python-confection
+ (package
+ (name "python-confection")
+ (version "0.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "confection" version))
+ (sha256
+ (base32
+ "1ksfn10zhnpkcj3y0c3xs4dznvc062bk62x4c3ig0dd6bn4gbpdi"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-pydantic python-srsly
+ python-typing-extensions))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/explosion/confection")
+ (synopsis "Config system for Python")
+ (description "Confection is a lightweight library that offers a
+configuration system letting you conveniently describe arbitrary trees of
+objects.")
+ (license license:expat)))
+
(define-public python-configobj
(package
(name "python-configobj")