summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-23 14:42:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-23 20:39:13 +0300
commit0ad3cc75aebc4794b38cfa5ef1c8fb8061def1fb (patch)
tree394d3f7601ca4cd0da5ceb744a593c366dde7ad8 /gnu
parent4ab8657b23ed951c6a95d18b4574e39f3aceca32 (diff)
gnu: shared-mime-info: Fix cross-compiling.
* gnu/packages/freedesktop.scm (shared-mime-info)[native-inputs]: When cross-compiling add libxml2 and this-package. Change-Id: I254a685a492b9080342b134ff23d9ccab0ecec3d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a77dab5794..c1a84185e1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -579,9 +579,13 @@ display servers. It supports many different languages and emoji.")
(inputs
(list glib libxml2))
(native-inputs
- (list gettext-minimal pkg-config python xdgmime
- ;; For 'doc' output.
- docbook-xml-4.1.2 docbook-xsl xmlto))
+ (append
+ (if (%current-target-system)
+ (list libxml2 this-package)
+ '())
+ (list gettext-minimal pkg-config python xdgmime
+ ;; For 'doc' output.
+ docbook-xml-4.1.2 docbook-xsl xmlto)))
(outputs (list "out" "doc"))
(home-page "https://www.freedesktop.org/wiki/Software/shared-mime-info")
(synopsis "Database of common MIME types")