summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-05-10 00:23:06 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-21 22:16:36 +0100
commit0d6815ae82da1f0202f345ef701dd45a998d54fb (patch)
tree7c4472076f27e242ef7e0b05a7d01979599e8224 /gnu
parentabc62671e0f907938f841fc9726468b3293ccd2c (diff)
gnu: podman: Update to 5.0.2.
* gnu/packages/containers.scm (podman): Update to 5.0.2. Change-Id: Id12c017e68f30db4ea99547beca54dbd01e3b029 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/containers.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index a6b6f588cf..65d24fd46f 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -49,6 +49,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages networking)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages rust-apps)
#:use-module (gnu packages selinux)
#:use-module (gnu packages version-control)
#:use-module (gnu packages virtualization)
@@ -413,7 +414,7 @@ The binary is called @command{gvproxy}.")
(define-public podman
(package
(name "podman")
- (version "4.9.3")
+ (version "5.0.2")
(source
(origin
(method git-fetch)
@@ -428,7 +429,7 @@ The binary is called @command{gvproxy}.")
(search-patches
"podman-program-lookup.patch"))
(sha256
- (base32 "17g7n09ndxhpjr39s9qwxdcv08wavjj0g5nmnrvrkz2wgdqigl1x"))
+ (base32 "0x8npz0i3dyiaw30vdlb5n8kiaflgjqnrdbdk0yn5zgf5k1jlb7i"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
@@ -459,7 +460,9 @@ The binary is called @command{gvproxy}.")
(("@SLIRP4NETNS_DIR@")
(string-append #$slirp4netns "/bin"))
(("@PASST_DIR@")
- (string-append #$passt "/bin")))
+ (string-append #$passt "/bin"))
+ (("@NETAVARK_DIR@")
+ (string-append #$netavark "/bin")))
(substitute* "hack/install_catatonit.sh"
(("CATATONIT_PATH=\"[^\"]+\"")
(string-append "CATATONIT_PATH=" (which "true"))))