summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-09-16 14:03:11 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-16 17:46:57 +0200
commit0dc83ce53b8bad8473c80689ba212d9f9bb712b3 (patch)
tree4a0d18a71c1ec1dedc038030e4d8157e7d242760 /gnu
parente4fdf062dcd1d7ad7ab8b0d50119a315d3df3095 (diff)
gnu: gnome-dictionary: Fix build.
* gnu/packages/patches/gnome-dictionary-meson-i18n.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/gnome.scm (gnome-dictionary): Use it here. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Fixes: gnome-dictionary-40.0: fails configure <https://bugs.gnu.org/63687>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm4
-rw-r--r--gnu/packages/patches/gnome-dictionary-meson-i18n.patch52
3 files changed, 56 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index c52917a4c5..672050723f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1306,6 +1306,7 @@ dist_patch_DATA = \
%D%/packages/patches/gnash-fix-giflib-version.patch \
%D%/packages/patches/gnome-2048-fix-positional-argument.patch \
%D%/packages/patches/gnome-control-center-libexecdir.patch \
+ %D%/packages/patches/gnome-dictionary-meson-i18n.patch \
%D%/packages/patches/gnome-online-miners-tracker-3.patch \
%D%/packages/patches/gnome-settings-daemon-gc.patch \
%D%/packages/patches/gnome-session-support-elogind.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 36fe1a80a1..908b5782b5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10497,7 +10497,9 @@ like automatic language detection, text-to-speech and clipboard buttons.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1d8dhcfys788vv27v34i3s3x3jdvdi2kqn2a5p8c937a9hm0qr9f"))))
+ "1d8dhcfys788vv27v34i3s3x3jdvdi2kqn2a5p8c937a9hm0qr9f"))
+ (patches
+ (search-patches "gnome-dictionary-meson-i18n.patch"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
diff --git a/gnu/packages/patches/gnome-dictionary-meson-i18n.patch b/gnu/packages/patches/gnome-dictionary-meson-i18n.patch
new file mode 100644
index 0000000000..fea45af69a
--- /dev/null
+++ b/gnu/packages/patches/gnome-dictionary-meson-i18n.patch
@@ -0,0 +1,52 @@
+From 71933f6586475b36c70ef325373fe6d50c7a034f Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 24 Jan 2022 11:13:54 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/appdata/meson.build:3:5: ERROR: Function does not take positional arguments.
+data/meson.build:6:5: ERROR: Function does not take positional arguments.
+data/meson.build:49:5: ERROR: Function does not take positional arguments.
+---
+ data/appdata/meson.build | 2 +-
+ data/meson.build | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/data/appdata/meson.build b/data/appdata/meson.build
+index 1dc4ed7..e44a58e 100644
+--- a/data/appdata/meson.build
++++ b/data/appdata/meson.build
+@@ -1,6 +1,6 @@
+ appdata_conf = configuration_data()
+ appdata_conf.set('application_id', application_id)
+-i18n.merge_file('appdata',
++appdata_file = i18n.merge_file(
+ input: configure_file(
+ input: 'org.gnome.Dictionary.appdata.xml.in.in',
+ output: 'org.gnome.Dictionary.appdata.xml.in',
+diff --git a/data/meson.build b/data/meson.build
+index 660e6b8..7ec7251 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -3,7 +3,7 @@ subdir('appdata')
+ desktop_conf = configuration_data()
+ desktop_conf.set('icon', application_id)
+ desktop_conf.set('application_id', application_id)
+-i18n.merge_file('desktop',
++desktop_file = i18n.merge_file(
+ input: configure_file(
+ input: 'org.gnome.Dictionary.desktop.in.in',
+ output: 'org.gnome.Dictionary.desktop.in',
+@@ -45,7 +45,7 @@ sources = [
+ ]
+
+ foreach s: sources
+- i18n.merge_file('sources',
++ i18n.merge_file(
+ input: '@0@.in'.format(s),
+ output: s,
+ install: true,
+--
+2.41.0
+