summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:35:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:45 +0200
commit0e5d890d32b4fc539435cc9156a4dccf99e60e08 (patch)
treeb34ffc53daebecab4c6d423dde4bc6e28b03e1e0 /gnu
parentb85ace3a562d90cbc8417459caa1adbdd7d5bcf4 (diff)
gnu: Add texlive-pst-stru.
* gnu/packages/tex.scm (texlive-pst-stru): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 251f8d66d4..98ee284bb9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34125,6 +34125,26 @@ exists under different forms with 2, 3 poles and even more. We chose the most
popular model: the triple fidget spinner.")
(license license:lppl)))
+(define-public texlive-pst-stru
+ (package
+ (name "texlive-pst-stru")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-stru/"
+ "tex/generic/pst-stru/"
+ "tex/latex/pst-stru/")
+ (base32
+ "1zxf0bj43picgd86bwgc38d8valpx0fn0pr3pgfv2kn42r2pampj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-stru")
+ (synopsis "Civil engineering diagrams, using PSTricks")
+ (description
+ "This PSTricks-based package provides facilities to draw structural
+schemes in civil engineering analysis, for beams, portals, arches and piles.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")