summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:01 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:55 +0000
commit1132921ea6a978941e27cdbbf69cd0108fa77af9 (patch)
tree41b4f0e823a6356b5ed710e5a3f8280b75f61ea5 /gnu
parent7d15ed9c825d82ab4841de281d7854f386ee98dd (diff)
gnu: Add ocaml-mirage-unix.
* gnu/packages/ocaml.scm (ocaml-mirage-unix): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0093ef0032..ca53dd67ee 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3800,6 +3800,27 @@ unsigned 64 bit integer. This has a range of up to 584 years. Functions
provided check the input and raise on negative or out of bound input.")
(license license:isc)))
+(define-public ocaml-mirage-unix
+ (package
+ (name "ocaml-mirage-unix")
+ (version "5.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mirage/mirage-unix/releases/download/v"
+ version "/mirage-unix-5.0.1.tbz"))
+ (sha256
+ (base32
+ "1y44hvsd5lxqbazwkv9n6cn936lpn8l7v82wf55w4183fp70nnjk"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-lwt ocaml-duration ocaml-mirage-runtime))
+ (home-page "https://github.com/mirage/mirage-unix")
+ (synopsis "Unix core platform libraries for MirageOS")
+ (description
+ "This package provides the MirageOS `OS` library for Unix targets, which
+handles the main loop and timers.")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")