summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-23 12:53:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-23 20:39:13 +0300
commit114333956e529cf1c6a0de2b9a15f04882ffd27f (patch)
tree38c76eff8a472bb5e10c47496a5951751a6bb96d /gnu
parent02427ea997e7218bccabb204d78b3469a63f32a7 (diff)
gnu: gnome-meta-core-utilities: Add eog unconditionally.
eog was removed because it required librsvg built with rust, but gnome-shell also requires the same librsvg already, so there was no reason to limit the architectures eog was installed on. * gnu/packages/gnome.scm (gnome-meta-core-utilities)[propagated-inputs]: Add eog unconditionally. Change-Id: I333d1a712b1d04409f3deccc90aa5adb2a4fac1b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4b7d53b089..62a6aacfe4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10326,14 +10326,9 @@ playing media, scanning, and much more.")
(gnome-meta-package
(name "gnome-meta-core-utilities")
(propagated-inputs
- (append
- ;; XXX: EoG requires librsvg-next, which depends on Rust, which currently
- ;; only works on x86_64, so exclude it on other architectures.
- (if (string-prefix? "x86_64" (%current-system))
- (list eog)
- '())
(list baobab
cheese
+ eog
epiphany
evince
file-roller
@@ -10358,7 +10353,7 @@ playing media, scanning, and much more.")
totem
tracker-miners
xdg-desktop-portal-gnome
- yelp)))))
+ yelp))))
(define-public gnome-essential-extras
(gnome-meta-package