summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:29:06 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:30 -0400
commit1261ca098b81b61ed2907c367a05077da591b29d (patch)
treea4ae7320b75864d43d224a349f74539ff5259aaf /gnu
parenteeb397018d5a52a074ae0432a9beb4f1af020403 (diff)
gnu: go-github-com-frankban-quicktest: Move to (gnu packages golang-check).
* gnu/packages/golang-check.scm (go-github-com-frankban-quicktest): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-check.scm27
-rw-r--r--gnu/packages/golang.scm26
2 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index d10eced626..82bcfcd28c 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
@@ -74,6 +75,32 @@
@end itemize\n")
(license license:expat))))
+(define-public go-github-com-frankban-quicktest
+ (package
+ (name "go-github-com-frankban-quicktest")
+ (version "1.11.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/frankban/quicktest")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b1b44b2hli2p969gqz30z8v9z6ahlklpqzi17nwk1lsjz9yv938"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/frankban/quicktest"))
+ (propagated-inputs
+ (list go-github-com-google-go-cmp-cmp go-github-com-kr-pretty))
+ (home-page "https://github.com/frankban/quicktest")
+ (synopsis "Quick helpers for testing Go applications")
+ (description
+ "Package quicktest provides a collection of Go helpers for writing
+tests.")
+ (license license:expat)))
+
(define-public go-github-com-google-gofuzz
(let ((commit "fd52762d25a41827db7ef64c43756fd4b9f7e382")
(revision "0"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d43b43f905..8860ec50fe 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10799,32 +10799,6 @@ is unchanged. This package contains a series of small enhancements and
additions.")
(license license:bsd-3))))
-(define-public go-github-com-frankban-quicktest
- (package
- (name "go-github-com-frankban-quicktest")
- (version "1.11.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/frankban/quicktest")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0b1b44b2hli2p969gqz30z8v9z6ahlklpqzi17nwk1lsjz9yv938"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/frankban/quicktest"))
- (propagated-inputs
- (list go-github-com-google-go-cmp-cmp go-github-com-kr-pretty))
- (home-page "https://github.com/frankban/quicktest")
- (synopsis "Quick helpers for testing Go applications")
- (description
- "Package quicktest provides a collection of Go helpers for writing
-tests.")
- (license license:expat)))
-
(define-public go-github-com-bep-golibsass
(package
(name "go-github-com-bep-golibsass")