summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-07-21 12:38:08 +0200
committerMarius Bakke <marius@gnu.org>2022-09-01 17:24:00 +0200
commit1499aa8773c1671aacd3d082d431cda67c2a22a1 (patch)
treee7b976a549d7ca34e46ddf4bb90e0803eaa7d2a9 /gnu
parentfd2c8cf3236c185a037abc31ad6ee4885b01e6c3 (diff)
gnu: kmplayer: Update to specific commit.
* gnu/packages/kde-multimedia.scm (kmplayer): Update to specific commit. [source]: Switch to GIT-FETCH. * gnu/packages/patches/kmplayer-aarch64.patch: Remove file. * gnu/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch: Remove file. * gnu/local.mk: Remove patches. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/kde-multimedia.scm106
-rw-r--r--gnu/packages/patches/kmplayer-aarch64.patch57
-rw-r--r--gnu/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch42
4 files changed, 55 insertions, 152 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index bd5889310f..1c4c102e11 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1373,8 +1373,6 @@ dist_patch_DATA = \
%D%/packages/patches/kismet-unbundle-boost.patch \
%D%/packages/patches/kmod-module-directory.patch \
%D%/packages/patches/kmscon-runtime-keymap-switch.patch \
- %D%/packages/patches/kmplayer-aarch64.patch \
- %D%/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch \
%D%/packages/patches/kobodeluxe-paths.patch \
%D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch \
%D%/packages/patches/kobodeluxe-const-charp-conversion.patch \
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
index b9d3ea3bf4..6fe6db0681 100644
--- a/gnu/packages/kde-multimedia.scm
+++ b/gnu/packages/kde-multimedia.scm
@@ -605,55 +605,59 @@ This package is part of the KDE multimedia module.")
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
(define-public kmplayer
- (package
- (name "kmplayer")
- (version "0.12.0b")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/kmplayer/0.12"
- "/kmplayer-" version ".tar.bz2"))
- (sha256
- (base32 "0wzdxym4fc83wvqyhcwid65yv59a2wvp1lq303cn124mpnlwx62y"))
- (patches (search-patches
- "kmplayer-aarch64.patch"
- "kmplayer-upstream_Fix-build-with-Qt-5.9.patch"))))
- (build-system qt-build-system)
- (native-inputs
- (list extra-cmake-modules pkg-config kdoctools))
- (inputs
- (list kbookmarks
- kconfig
- kcoreaddons
- kdelibs4support
- ki18n
- kinit
- kio
- kparts
- kmediaplayer
- kwidgetsaddons
- libxcb ;; FIXME: why does cmake not find XEVIE and XPRINT?
- oxygen-icons ; default icon set
- phonon
- qtbase-5
- cairo
- qtsvg-5
- qtx11extras
- xcb-util
- xcb-util-cursor
- xcb-util-errors
- xcb-util-image
- xcb-util-keysyms
- xcb-util-wm))
- (arguments
- (list #:configure-flags
- #~(list (string-append
- "-DCMAKE_CXX_FLAGS=-I"
- #$(this-package-input "qtx11extras")
- "/include/qt5"))))
- (home-page "https://apps.kde.org/kmplayer/")
- (synopsis "Media player using mplayer/phonon as backend")
- (description "Kmplayer can play all the audio/video supported by
+ ;; The latest release was in 2016, and does not work with the newer
+ ;; KDE libraries.
+ (let ((commit "88e85308b71dc5e58cc655b5b9a13cd71b78233f")
+ (revision "1"))
+ (package
+ (name "kmplayer")
+ (version (git-version "0.12.0b" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://invent.kde.org/multimedia/kmplayer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pzk0js499diqabpwxjq6nnwpmj1ikpyyykzjbm844xcbm74cl19"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules pkg-config kdoctools))
+ (inputs
+ (list kbookmarks
+ kconfig
+ kcoreaddons
+ kdelibs4support
+ ki18n
+ kinit
+ kio
+ kparts
+ kmediaplayer
+ kwidgetsaddons
+ libxcb ;; FIXME: why does cmake not find XEVIE and XPRINT?
+ oxygen-icons ; default icon set
+ phonon
+ qtbase-5
+ cairo
+ qtsvg-5
+ qtx11extras
+ xcb-util
+ xcb-util-cursor
+ xcb-util-errors
+ xcb-util-image
+ xcb-util-keysyms
+ xcb-util-wm))
+ (arguments
+ (list #:configure-flags
+ #~(list (string-append
+ "-DCMAKE_CXX_FLAGS=-I"
+ #$(this-package-input "qtx11extras")
+ "/include/qt5"))))
+ (home-page "https://apps.kde.org/kmplayer/")
+ (synopsis "Media player using mplayer/phonon as backend")
+ (description "Kmplayer can play all the audio/video supported by
mplayer/phonon from a local file or URL and be embedded in Konqueror and
KHTML. It also plays DVDs.
@@ -667,8 +671,8 @@ Some features:
@item Broadcasting, http streaming, using ffserver/ffmpeg
@item For TV sources, you need v4lctl (part of the xawtv package)
@end itemize")
- (license ;; GPL for programs, LGPL for libraries, FDL for documentation
- (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+ (license ;; GPL for programs, LGPL for libraries, FDL for documentation
+ (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+)))))
(define-public kwave
(package
diff --git a/gnu/packages/patches/kmplayer-aarch64.patch b/gnu/packages/patches/kmplayer-aarch64.patch
deleted file mode 100644
index 76f713be96..0000000000
--- a/gnu/packages/patches/kmplayer-aarch64.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-Index: b/src/moz-sdk/prcpucfg.h
-===================================================================
---- a/src/moz-sdk/prcpucfg.h
-+++ b/src/moz-sdk/prcpucfg.h
-@@ -288,6 +288,52 @@
- #define PR_BYTES_PER_WORD_LOG2 3
- #define PR_BYTES_PER_DWORD_LOG2 3
-
-+#elif defined(__aarch64__)
-+
-+#define IS_LITTLE_ENDIAN 1
-+#undef IS_BIG_ENDIAN
-+#define IS_64
-+
-+#define PR_BYTES_PER_BYTE 1
-+#define PR_BYTES_PER_SHORT 2
-+#define PR_BYTES_PER_INT 4
-+#define PR_BYTES_PER_INT64 8
-+#define PR_BYTES_PER_LONG 8
-+#define PR_BYTES_PER_FLOAT 4
-+#define PR_BYTES_PER_DOUBLE 8
-+#define PR_BYTES_PER_WORD 8
-+#define PR_BYTES_PER_DWORD 8
-+
-+#define PR_BITS_PER_BYTE 8
-+#define PR_BITS_PER_SHORT 16
-+#define PR_BITS_PER_INT 32
-+#define PR_BITS_PER_INT64 64
-+#define PR_BITS_PER_LONG 64
-+#define PR_BITS_PER_FLOAT 32
-+#define PR_BITS_PER_DOUBLE 64
-+#define PR_BITS_PER_WORD 64
-+
-+#define PR_BITS_PER_BYTE_LOG2 3
-+#define PR_BITS_PER_SHORT_LOG2 4
-+#define PR_BITS_PER_INT_LOG2 5
-+#define PR_BITS_PER_INT64_LOG2 6
-+#define PR_BITS_PER_LONG_LOG2 6
-+#define PR_BITS_PER_FLOAT_LOG2 5
-+#define PR_BITS_PER_DOUBLE_LOG2 6
-+#define PR_BITS_PER_WORD_LOG2 6
-+
-+#define PR_ALIGN_OF_SHORT 2
-+#define PR_ALIGN_OF_INT 4
-+#define PR_ALIGN_OF_LONG 8
-+#define PR_ALIGN_OF_INT64 8
-+#define PR_ALIGN_OF_FLOAT 4
-+#define PR_ALIGN_OF_DOUBLE 8
-+#define PR_ALIGN_OF_POINTER 8
-+#define PR_ALIGN_OF_WORD 8
-+
-+#define PR_BYTES_PER_WORD_LOG2 3
-+#define PR_BYTES_PER_DWORD_LOG2 3
-+
- #elif defined(__mc68000__)
-
- #undef IS_LITTLE_ENDIAN
diff --git a/gnu/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch b/gnu/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch
deleted file mode 100644
index 6a40dbe347..0000000000
--- a/gnu/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 3def65075c09af4961cd399e8e78ed78cca72e65 Mon Sep 17 00:00:00 2001
-From: Wolfgang Bauer <wbauer@tmo.at>
-Date: Wed, 11 Oct 2017 22:16:02 +0200
-Subject: [PATCH] Fix build with Qt 5.9
-
-Summary:
-moc 5.9 errors out when building:
-Error: Plugin Metadata file "" could not be opened: file to open is a directory
-
-Same issue and fix as https://phabricator.kde.org/D5392 for khtml.
-
-CCBUG: 377490
-
-Test Plan: builds fine now with Qt 5.9.0rc and also earlier versions.
-
-Reviewers: vriezen, pino
-
-Reviewed By: pino
-
-Subscribers: pino
-
-Differential Revision: https://phabricator.kde.org/D5985
----
- src/kmplayer_part.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/kmplayer_part.h b/src/kmplayer_part.h
-index f90f85d..0fddbaa 100644
---- a/src/kmplayer_part.h
-+++ b/src/kmplayer_part.h
-@@ -36,7 +36,7 @@ namespace KMPlayer {
-
- class KMPlayerFactory : public KPluginFactory {
- Q_OBJECT
-- Q_PLUGIN_METADATA(IID "org.kde.KPluginFactory" FILE "")
-+ Q_PLUGIN_METADATA(IID "org.kde.KPluginFactory")
- Q_INTERFACES(KPluginFactory)
- public:
- KMPlayerFactory();
---
-2.14.2
-