summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-29 17:01:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-30 16:46:17 +0100
commit173a2998d9facce29386788d25bcc08781386f60 (patch)
treee3c3bad049f901c677725e461d508cefcead778f /gnu
parentd95a982cdd898790d247f013440f08a448265e3f (diff)
gnu: r-umi4cpackage: Embed references to perl and bowtie2.
* gnu/packages/bioinformatics.scm (r-umi4cpackage)[arguments]: Add build phases to patch calls of bowtie2 and perl. [inputs]: Add perl and bowtie. [synopsis]: Remove trailing period.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 67335daead..dffd59d863 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7812,12 +7812,27 @@ single cell ATAC-seq sequencing data.")
(base32 "0bjzamdw2lcfhlbzc0vdva87c3wwnij8jsvnrpx4wyyxvpcz13m5"))))
(properties `((upstream-name . "umi4cPackage")))
(build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-references
+ (lambda _
+ (substitute* "inst/conf/paths.conf"
+ (("TG3C\\.bowtie2_bin=.*")
+ (string-append "TG3C.bowtie2_bin="
+ (which "bowtie2") "\n")))
+ (substitute* "inst/perl/map3c/TG3C/import3C.pl"
+ (("\"perl")
+ (string-append "\"" (which "perl")))))))))
+ (inputs
+ `(("perl" ,perl)
+ ("bowtie" ,bowtie)))
(propagated-inputs
`(("r-misha" ,r-misha)
("r-zoo" ,r-zoo)))
(native-inputs `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/tanaylab/umi4cpackage")
- (synopsis "Processing and analysis of UMI-4C contact profiles.")
+ (synopsis "Processing and analysis of UMI-4C contact profiles")
(description "This is a package that lets you process UMI-4C data from
scratch to produce nice plots.")
(license license:expat))))