summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-02 23:00:22 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-02 23:08:19 +0200
commit1747bb482511dc70735fd5d657812a9d422b1ab2 (patch)
treea32beb28e33682c5699a175fa8bc553c3808e597 /gnu
parentf46ae49b13b78e054e402db778a86ccfafdf7eab (diff)
gnu: python-httpx: Honor #:tests? flag.
* gnu/packages/python-web.scm (python-httpx)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 62de043e70..8a72f33a91 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5283,18 +5283,19 @@ Some things HTTP Core does do:
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest" "-vv" "-k"
- ;; These tests try to open an outgoing connection.
- (string-append
- "not test_connect_timeout"
- " and not test_that_send_cause_async_client_to_be_not_"
- "closed"
- " and not test_that_async_client_caused_warning_when_"
- "being_deleted"
- " and not test_that_send_cause_client_to_be_not_closed"
- " and not test_async_proxy_close"
- " and not test_sync_proxy_close")))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "-k"
+ ;; These tests try to open an outgoing connection.
+ (string-append
+ "not test_connect_timeout"
+ " and not test_that_send_cause_async_client_to_be_not_"
+ "closed"
+ " and not test_that_async_client_caused_warning_when_"
+ "being_deleted"
+ " and not test_that_send_cause_client_to_be_not_closed"
+ " and not test_async_proxy_close"
+ " and not test_sync_proxy_close"))))))))
(native-inputs
`(("python-autoflake" ,python-autoflake)
("python-black" ,python-black)