summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndrew Jose <arnav.jose@gmail.com>2023-09-21 18:14:53 +0530
committerEfraim Flashner <efraim@flashner.co.il>2023-09-28 21:17:19 +0300
commit188730c17c129a76822aed89761b763f19a37402 (patch)
treed7c817f1f5d260fb02f162d857f6802000cbe9de /gnu
parent27b64d3efa80b31ebba07742618c6351e1fbb232 (diff)
gnu: Add rust-dotenvy-0.15.
* gnu/packages/crates-io.scm (rust-dotenvy-0.15): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c4a22857f1..a42f139829 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20967,6 +20967,37 @@ Rust.")
("rust-regex" ,rust-regex-0.2)
("rust-syn" ,rust-syn-0.11))))))
+(define-public rust-dotenvy-0.15
+ (package
+ (name "rust-dotenvy")
+ (version "0.15.7")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "dotenvy" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16s3n973n5aqym02692i1npb079n5mb0fwql42ikmwn8wnrrbbqs"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-test-flags
+ ;; Not all files included.
+ '("--release" "--"
+ "--skip=dotenv"
+ "--skip=dotenv_iter"
+ "--skip=dotenv_override"
+ "--skip=from_filename"
+ "--skip=from_filename_override")
+ #:cargo-inputs
+ (("rust-clap" ,rust-clap-3))
+ #:cargo-development-inputs
+ (("rust-once-cell" ,rust-once-cell-1)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (home-page "https://github.com/allan2/dotenvy")
+ (synopsis "Fork of the dotenv crate")
+ (description "This package provides a fork of the dotenv crate.")
+ (license license:expat)))
+
(define-public rust-draw-state-0.8
(package
(name "rust-draw-state")