summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-12 22:59:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 22:59:41 +0200
commit1a21f4117e2d0032d24e682e2588502357a10ba5 (patch)
tree00b9ea25c72be793c13e5fabf0226fa7a2712fde /gnu
parentdb3d74008a30fb200c46e13b31a6e79ef5439942 (diff)
gnu: python-pyproject-metadata: Simplify by using pyproject-build-system.
* gnu/packages/python-xyz.scm (python-pyproject-metadata)[arguments]: Remove. [build-system]: Use pyproject-build-system.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 1 insertions, 25 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1dc9c84f7f..5de9ff1bb2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11912,31 +11912,7 @@ plugin for flake8 to check PEP-8 naming conventions.")
(sha256
(base32
"00zahgw9zjfqwf0218bj5k732aibnn68cq1p8f0wmbirb7fy5k31"))))
- (build-system python-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- ;; XXX: PEP 517 manual build/install procedures copied from
- ;; python-isort.
- (replace 'build
- (lambda _
- ;; ZIP does not support timestamps before 1980.
- (setenv "SOURCE_DATE_EPOCH" "315532800")
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv"
- ;; Two parameterized test_load tests are currently
- ;; failing (see:
- ;; https://github.com/FFY00/python-pep621/issues/14).
- "-k" "not test_load"))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl)))))))
+ (build-system pyproject-build-system)
(propagated-inputs (list python-packaging))
(native-inputs (list python-pypa-build python-pytest python-tomli))
(home-page "https://github.com/FFY00/python-pyproject-metadata")