summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-06-24 09:48:04 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-06-24 10:15:23 +0300
commit1a29159342b8ccbdc1c6d544dad4e1bae61db0c9 (patch)
tree6fc2d1de9112e3fb5908bcdac33ff05f3fe2b1e7 /gnu
parent36ba88da4a18d4e93f08f7296cc20ab775828036 (diff)
gnu: streamlink: Update to 0.13.0-1.2dca793.
* gnu/packages/video.scm (streamlink): Update to 0.13.0-1.2dca793.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm62
1 files changed, 35 insertions, 27 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index af45f0f3db..ce90d470f4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -123,6 +123,7 @@
#:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages time)
#:use-module (gnu packages upnp)
#:use-module (gnu packages version-control)
#:use-module (gnu packages vulkan)
@@ -1813,34 +1814,41 @@ and custom quantization matrices.")
(license license:gpl2+)))
(define-public streamlink
- (package
- (name "streamlink")
- (version "0.11.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "streamlink" version))
- (sha256
- (base32
- "02h8b3k8l5zz4vjm0nhxvl1pm924jms8y7sjl40fbybrzvsa4mg2"))))
- (build-system python-build-system)
- (home-page "https://github.com/streamlink/streamlink")
- (native-inputs
- `(("python-pytest" ,python-pytest)
- ("python-mock" ,python-mock)
- ("python-requests-mock" ,python-requests-mock)))
- (propagated-inputs
- `(("python-pysocks" ,python-pysocks)
- ("python-websocket-client" ,python-websocket-client)
- ("python-iso3166" ,python-iso3166)
- ("python-iso639" ,python-iso639)
- ("python-pycryptodome" ,python-pycryptodome)
- ("python-requests" ,python-requests)
- ("python-urllib3" ,python-urllib3)))
- (synopsis "Extract streams from various services")
- (description "Streamlink is command-line utility that extracts streams
+ ;; Release tarball doesn't contain ‘tests/resources/dash/’ directory.
+ (let ((commit "2dca7930a938f60b48d8e23260963ea7c49d979f"))
+ (package
+ (name "streamlink")
+ (version (git-version "0.13.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/streamlink/streamlink.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vq19aspshim63aj8yl2p64ykrbk2mwwlawdx427b3j2djlc5qhw"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/streamlink/streamlink")
+ (native-inputs
+ `(("python-freezegun" ,python-freezegun)
+ ("python-pytest" ,python-pytest)
+ ("python-mock" ,python-mock)
+ ("python-requests-mock" ,python-requests-mock)))
+ (propagated-inputs
+ `(("python-pysocks" ,python-pysocks)
+ ("python-websocket-client" ,python-websocket-client)
+ ("python-iso3166" ,python-iso3166)
+ ("python-iso639" ,python-iso639)
+ ("python-isodate", python-isodate)
+ ("python-pycryptodome" ,python-pycryptodome)
+ ("python-requests" ,python-requests)
+ ("python-urllib3" ,python-urllib3)))
+ (synopsis "Extract streams from various services")
+ (description "Streamlink is command-line utility that extracts streams
from sites like Twitch.tv and pipes them into a video player of choice.")
- (license license:bsd-2)))
+ (license license:bsd-2))))
(define-public livestreamer
(deprecated-package "livestreamer" streamlink))