summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-13 00:23:17 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-02-17 15:46:47 +0100
commit1a8a78a0c4f2bad3f33ec692464ef0b64b3af103 (patch)
tree993192cc6b70282a94ea45638810582034e4208b /gnu
parentcb45e9d0dc6cbe6f69a858f71252411610b4ce82 (diff)
gnu: cl-croatoan: Update to 0.0.1-7.42e474f.
* gnu/packages/lisp-xyz.scm (sbcl-croatoan): Update to 0.0.1-7.42e474f. [arguments]{phases}(fix-paths): Use search-input-file procedure. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 3648e12db1..7684ee6e48 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17213,8 +17213,8 @@ protocol for Mastodon.")
(sbcl-package->cl-source-package sbcl-tooter))
(define-public sbcl-croatoan
- (let ((commit "35c92fcc6c4458339c7e27bdf16f7fa908d95eb8")
- (revision "6"))
+ (let ((commit "42e474f4dffe2f4e429905a612be5736c2c3e374")
+ (revision "7"))
(package
(name "sbcl-croatoan")
(version (git-version "0.0.1" revision commit))
@@ -17226,7 +17226,7 @@ protocol for Mastodon.")
(commit commit)))
(file-name (git-file-name "cl-croatoan" version))
(sha256
- (base32 "0v1lrdjd29krjb6pr0mql9hjj5c2lv760xwpr17dbsw263vx29xz"))))
+ (base32 "12hnj8gwk2600j3kn778xvvpx3y6z0428v5dq2qbf4vbzj66vcxj"))))
(build-system asdf-build-system/sbcl)
(arguments
'(#:phases
@@ -17234,10 +17234,8 @@ protocol for Mastodon.")
(add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "ncurses/ncurses.lisp"
- (("libncursesw" all)
- (string-append (assoc-ref inputs "ncurses")
- "/lib/"
- all))))))))
+ (("libncursesw.so")
+ (search-input-file inputs "/lib/libncursesw.so"))))))))
(inputs
(list ncurses
sbcl-cffi