summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:05:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:19 +0200
commit1ac96578a7c52d21ad1e02fd2b6b827841306c23 (patch)
tree5e57c4209f948fa129f6bb490c48a01943f50969 /gnu
parentdbc79aa6d852f18238cf64674f0a0bf3c2dc1d56 (diff)
gnu: Add texlive-uiucthesis.
* gnu/packages/tex.scm (texlive-uiucthesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index aa3d37a2e3..2bd71a3ed5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -30705,6 +30705,26 @@ that gets signed by the department head, your advisor, and --- for
doctoral dissertations --- your thesis committee members.")
(license license:lppl1.2+)))
+(define-public texlive-uiucthesis
+ (package
+ (name "texlive-uiucthesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/uiucthesis/"
+ "source/latex/uiucthesis/"
+ "tex/latex/uiucthesis/")
+ (base32
+ "0kzp2p03p1v7qij2kz82xis88vh1g477vs2aa0sqfa24w9y28h5i")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/uiucthesis")
+ (synopsis "UIUC thesis class")
+ (description
+ "The class produces a document that conforms to the format described in
+the University's Handbook for Graduate Students Preparing to Deposit.")
+ (license license:lppl)))
+
(define-public texlive-ulqda
(package
(name "texlive-ulqda")