summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:45:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:18 +0200
commit1bd8f4e1cb2b287b9b1cc71a44865a4cb25affe2 (patch)
treeb3d35dc799b667f1eeec7e4125d762f7193d5762 /gnu
parent8cb294628a161776be1e69af9189b85c6345992e (diff)
gnu: Add texlive-lua-visual-debug.
* gnu/packages/tex.scm (texlive-lua-visual-debug): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 130cae2505..ab178273aa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16229,6 +16229,26 @@ In particular, kerning is not affected, the underlined text can use arbitrary
commands, hyphenation works etc.")
(license license:lppl1.3c)))
+(define-public texlive-lua-visual-debug
+ (package
+ (name "texlive-lua-visual-debug")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/lua-visual-debug/"
+ "tex/luatex/lua-visual-debug/")
+ (base32
+ "1g4n4xfqbgcja2x3b7yi59nn76jq695yndv90610pakask2k560l")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/lua-visual-debug")
+ (synopsis "Visual debugging with LuaLaTeX")
+ (description
+ "The package uses Lua code to provide visible indications of boxes,
+glues, kerns and penalties in the PDF output. The package is known to work in
+LaTeX and Plain TeX documents.")
+ (license license:expat)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")