summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-05-28 18:57:46 +0200
committerMarius Bakke <marius@gnu.org>2020-05-29 15:41:30 +0200
commit1ca44ae34cb4324427f232035b00c11dfa712139 (patch)
tree964497d5d6c047e83a58c21053982318048083bd /gnu
parentfb9a57a8e6a28093f5138a6c484442f8b3a8cd7e (diff)
gnu: Use 'cc-for-target' instead of custom implementations.
* gnu/packages/compression.scm (ecm)[arguments]: In #:make-flags, remove TARGET binding and use CC-FOR-TARGET instead. * gnu/packages/linux.scm (powerstat, crda, cachefilesd)[arguments]: Likewise. * gnu/packages/mail.scm (alpine)[arguments]: Likewise. * gnu/packages/music.scm (lsp-plugins)[arguments]: Likewise. * gnu/packages/radio.scm (dump1090)[arguments]: Likewise. * gnu/packages/suckless.scm (blind, dmenu, spoon, slock, st, surf, sent, wificurse, sbm, prout, noice, human, fortify-headers, colors, libutf, scron)[arguments]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm7
-rw-r--r--gnu/packages/linux.scm22
-rw-r--r--gnu/packages/mail.scm5
-rw-r--r--gnu/packages/music.scm6
-rw-r--r--gnu/packages/radio.scm7
-rw-r--r--gnu/packages/suckless.scm134
6 files changed, 52 insertions, 129 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 38adf35e33..cdab7408ed 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -2207,11 +2207,8 @@ computations.")
(arguments
`(#:tests? #f ; no check target
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "DESTDIR=" (assoc-ref %outputs "out"))))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "DESTDIR=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
(replace 'configure
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b159ff7b22..0a154fd6cc 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1222,11 +1222,8 @@ at login. Local and dynamic reconfiguration are its key features.")
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (let* ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "prefix=" (assoc-ref %outputs "out"))))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "prefix=" (assoc-ref %outputs "out")))
#:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
@@ -3377,12 +3374,9 @@ interface.")
#t))))
#:test-target "verify"
#:make-flags (let ((out (assoc-ref %outputs "out"))
- (regdb (assoc-ref %build-inputs "wireless-regdb"))
- (target ,(%current-target-system)))
+ (regdb (assoc-ref %build-inputs "wireless-regdb")))
(list
- (string-append
- "CC=" (if target
- (string-append target "-gcc") "gcc"))
+ (string-append "CC=" ,(cc-for-target))
"V=1"
;; Disable signature-checking on 'regulatory.bin'.
@@ -7040,12 +7034,8 @@ system boot process.")
`(#:tests? #f ; there are no tests
#:make-flags
(let ((prefix-dir (lambda (var dir)
- (string-append var "=" %output "/" dir)))
- (target ,(%current-target-system)))
- (list (string-append "CC="
- (if target
- (string-append target "-gcc")
- "gcc"))
+ (string-append var "=" %output "/" dir))))
+ (list (string-append "CC=" ,(cc-for-target))
(prefix-dir "SBINDIR" "sbin/")
(prefix-dir "ETCDIR" "etc/")
(prefix-dir "MANDIR" "share/man/")))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index b44afd360e..8fb2a3c39e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2697,10 +2697,7 @@ operators and scripters.")
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))))
+ (list (string-append "CC=" ,(cc-for-target)))
#:configure-flags (list (string-append "--with-ssl-include-dir="
(assoc-ref %build-inputs "openssl")
"/include/openssl")
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e4414dafd6..09827c7c93 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4886,11 +4886,7 @@ and reverb.")
(arguments
`(#:make-flags
(list
- (string-append "CC="
- (if ,(%current-target-system)
- (string-append (assoc-ref %build-inputs "cross-gcc")
- "/bin/" ,(%current-target-system) "-gcc")
- "gcc"))
+ (string-append "CC=" ,(cc-for-target))
"BUILD_MODULES=\"lv2 ladspa jack\"" "VST_UI=0"
(string-append "PREFIX=" (assoc-ref %outputs "out"))
(string-append "ETC_PATH=" (assoc-ref %outputs "out") "/etc"))
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 5d58602ab0..b3a7cc0e97 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1018,11 +1018,8 @@ gain and standing wave ratio.")
(arguments
`(#:test-target "test"
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- "BLADERF=no"))
+ (list (string-append "CC=" ,(cc-for-target))
+ "BLADERF=no")
#:phases
(modify-phases %standard-phases
(delete 'configure)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 5cabb40eb0..c10226bb32 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -46,6 +46,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
#:use-module (guix packages))
(define-public blind
@@ -62,12 +63,8 @@
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
- #:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ #:make-flags (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script
@@ -152,14 +149,11 @@ optimising the environment for the application in use and the task performed.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)
- (string-append "FREETYPEINC="
- (assoc-ref %build-inputs "freetype")
- "/include/freetype2")))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output)
+ (string-append "FREETYPEINC="
+ (assoc-ref %build-inputs "freetype")
+ "/include/freetype2"))
#:phases
(modify-phases %standard-phases (delete 'configure))))
(inputs
@@ -190,11 +184,8 @@ numbers of user-defined menu items efficiently.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))))
(inputs
`(("libx11" ,libx11)
("libxkbfile" ,libxkbfile)
@@ -221,11 +212,8 @@ numbers of user-defined menu items efficiently.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases (modify-phases %standard-phases (delete 'configure))))
(inputs
`(("libx11" ,libx11)
@@ -253,11 +241,8 @@ numbers of user-defined menu items efficiently.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)
@@ -298,11 +283,8 @@ drawing.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)
@@ -347,14 +329,11 @@ point surf to another URI by setting its XProperties.")
(delete 'configure)) ; no configuration
#:tests? #f ; no test suite
#:make-flags
- (let ((target ,(%current-target-system))
- (pkg-config (lambda (flag)
+ (let ((pkg-config (lambda (flag)
(string-append
"$(shell pkg-config " flag " "
"xft fontconfig x11 libpng)"))))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
+ (list (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" %output)
(string-append "INCS=-I. " (pkg-config "--cflags"))
(string-append "LIBS=" (pkg-config "--libs") " -lm")))))
@@ -390,11 +369,8 @@ few minutes.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))))
(inputs
`(("libx11" ,libx11)))
(home-page "https://git.2f30.org/xbattmon/")
@@ -452,11 +428,8 @@ drivers capable of injecting packets in wireless networks.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script
@@ -484,11 +457,8 @@ left.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script
@@ -514,11 +484,8 @@ left.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script
@@ -550,11 +517,8 @@ cups server to be installed.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure script
@@ -588,11 +552,8 @@ cups server to be installed.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script
@@ -621,11 +582,8 @@ environment variable.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script
@@ -666,11 +624,8 @@ initially intended to be used on musl-based Linux distributions.
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script
@@ -707,11 +662,8 @@ colormap to stdout.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script
@@ -756,11 +708,8 @@ as -1, to be used instead of U+FFFD.
(arguments
`(#:test-target "test"
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure script
@@ -805,11 +754,8 @@ chat output in the background.")
(arguments
`(#:tests? #f ; no tests
#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "CC=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "PREFIX=" %output)))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script