summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-12-08 20:22:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 18:40:11 +0100
commit1e5c9bb0d212dc4befb63d05e19c17d7de7e95ad (patch)
tree4271009bf10ddbb0b8dc0c4cb4e7c358c84d2b23 /gnu
parentc2d25c7b5ed1bdff7ba62e6f0981ce6f1eb53988 (diff)
gnu: Add r-ptw.
* gnu/packages/cran.scm (r-ptw): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cb857e8232..2fdc626ad5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4922,6 +4922,33 @@ approach is used to estimate the lower cut-off for the scaling region.")
;; Any of these GPL versions.
(license (list license:gpl2 license:gpl3))))
+(define-public r-ptw
+ (package
+ (name "r-ptw")
+ (version "1.9-16")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ptw" version))
+ (sha256
+ (base32
+ "0rma3h9ksc5qigdvk5vappb4ipd4rpk64wckzcxvxspakr5w71vy"))))
+ (properties `((upstream-name . "ptw")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcppde))
+ (home-page "https://github.com/rwehrens/ptw")
+ (synopsis "Parametric time warping")
+ (description
+ "Parametric time warping aligns patterns. It aims to put corresponding
+features at the same locations. The algorithm searches for an optimal
+polynomial describing the warping. It is possible to align one sample to a
+reference, several samples to the same reference, or several samples to
+several references. One can choose between calculating individual warpings,
+or one global warping for a set of samples and one reference. Two
+optimization criteria are implemented: @acronym{RMS, Root Mean Square} error
+and @acronym{WCC, Weighted Cross Correlation}. Both warping of peak profiles
+and of peak lists are supported.")
+ (license license:gpl2+)))
+
(define-public r-compare
(package
(name "r-compare")