summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-06-22 11:19:39 -0400
committerEfraim Flashner <efraim@flashner.co.il>2022-07-06 11:31:11 +0300
commit1ed0283fcc12b4b48f5b61be026a7b832d9781dc (patch)
tree93613a7c5d4f35ffb7aa7fce2c8656ce04e33800 /gnu
parentcf072876196cebb2962ef3681520331532636b96 (diff)
gnu: mesa: Update configure flags.
* gnu/packages/gl.scm (mesa)[configure-flags]: Adjust the gallium-drivers and vulkan-drivers flags to use "auto" where it is available and enables at least the previously listed drivers. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gl.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 6c4594a9a1..a46e06827d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
-;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -320,10 +320,10 @@ also known as DXTn or DXTC) for Mesa.")
("armhf-linux"
;; Freedreno FTBFS when built on a 64-bit machine.
'("-Dgallium-drivers=etnaviv,kmsro,lima,nouveau,panfrost,r300,r600,swrast,tegra,v3d,vc4,virgl"))
- ((or "powerpc64le-linux" "powerpc-linux" "riscv64-linux")
+ ((or "powerpc64le-linux" "powerpc-linux")
'("-Dgallium-drivers=nouveau,r300,r600,radeonsi,swrast,virgl"))
(_
- '("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
+ '("-Dgallium-drivers=auto")))
;; Enable various optional features. TODO: opencl requires libclc,
;; omx requires libomxil-bellagio
"-Dplatforms=x11,wayland"
@@ -340,14 +340,10 @@ also known as DXTn or DXTC) for Mesa.")
;; Explicitly enable Vulkan on some architectures.
,@(match (%current-system)
- ((or "i686-linux" "x86_64-linux")
- '("-Dvulkan-drivers=intel,amd"))
((or "powerpc64le-linux" "powerpc-linux")
'("-Dvulkan-drivers=amd,swrast"))
("aarch64-linux"
'("-Dvulkan-drivers=freedreno,amd,broadcom,swrast"))
- ("riscv64-linux"
- '("-Dvulkan-drivers=amd,swrast"))
(_
'("-Dvulkan-drivers=auto")))