summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-08-29 10:19:55 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-07 11:40:06 +0200
commit214452ffd339491f63560d19d2aeab4e668029a4 (patch)
treeb07454bf780665ddb20d1f15ac9e089cb3b75594 /gnu
parentc61f7bc543d98781d9c24989edbfde39af7e7320 (diff)
gnu: Add r-ggformula.
* gnu/packages/cran.scm (r-ggformula): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3be7fd7d62..8144391729 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5535,3 +5535,32 @@ and coverage methods to tune the choice of threshold.")
(description
"Common utilities used in other Mosaic family packages are collected here.")
(license license:gpl2+)))
+
+(define-public r-ggformula
+ (package
+ (name "r-ggformula")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggformula" version))
+ (sha256
+ (base32 "1pmpdfjfbrc6kcpq70cr1kbj2qy711hw940g2aiis6l443z706kh"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-ggstance" ,r-ggstance)
+ ("r-magrittr" ,r-magrittr)
+ ("r-mosaiccore" ,r-mosaiccore)
+ ("r-rlang" ,r-rlang)
+ ("r-stringr" ,r-stringr)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "https://github.com/ProjectMOSAIC/ggformula/")
+ (synopsis "Formula interface for the @code{r-ggplot2}")
+ (description
+ "The @code{r-ggformula} introduces a family of graphics functions, gf_point(),
+gf_density(), and so on, bring the formula interface to ggplot(). This captures
+and extends the excellent simplicity of the lattice-graphics formula interface,
+while providing the intuitive capabilities of @code{r-ggplot2}.")
+ (license license:expat)))