summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-14 15:36:05 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-05 21:31:54 +0300
commit246455c28701e71aa7e948859a0d3d6259596b99 (patch)
treed3a897d9b0974b5f20dd17287118af1458ba1207 /gnu
parenta022b23fa94f200a6c3e3cf9d7d05cdd704b7ab9 (diff)
gnu: Add perl-xml-feed.
* gnu/packages/xml.scm (perl-xml-feed): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index b2f51bd2ba..8e0fe01c6b 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -631,6 +631,45 @@ encoding of the message to be send into XML, sending the message to the
server, collect the answer, and finally decoding the XML to Perl.")
(license (package-license perl))))
+(define-public perl-xml-feed
+ (package
+ (name "perl-xml-feed")
+ (version "0.53")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DA/DAVECROSS/"
+ "XML-Feed-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07b165g6wk8kqwpl49r3n0kag6p2nrkyp3ch0h8qyxb6nrnkkq7c"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests require internet connection
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-uri" ,perl-uri)
+ ("perl-class-data-inheritable" ,perl-class-data-inheritable)))
+ (inputs
+ `(("perl-class-errorhandler" ,perl-class-errorhandler)
+ ("perl-datetime" ,perl-datetime)
+ ("perl-datetime-format-mail" ,perl-datetime-format-mail)
+ ("perl-datetime-format-w3cdtf" ,perl-datetime-format-w3cdtf)
+ ("perl-feed-find" ,perl-feed-find)
+ ("perl-html-parser" ,perl-html-parser)
+ ("perl-libwww-perl" ,perl-libwww)
+ ("perl-module-pluggable" ,perl-module-pluggable)
+ ("perl-uri-fetch" ,perl-uri-fetch)
+ ("perl-xml-atom" ,perl-xml-atom)
+ ("perl-xml-libxml" ,perl-xml-libxml)
+ ("perl-xml-rss" ,perl-xml-rss)))
+ (home-page "http://search.cpan.org/dist/XML-Feed")
+ (synopsis "XML Syndication Feed Support")
+ (description "@code{XML::Feed} is a syndication feed parser for both RSS and
+Atom feeds. It also implements feed auto-discovery for finding feeds, given a URI.
+@code{XML::Feed} supports the following syndication feed formats:
+RSS 0.91, RSS 1.0, RSS 2.0, Atom")
+ (license (package-license perl))))
+
(define-public perl-xml-xpath
(package
(name "perl-xml-xpath")