summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-08-07 19:37:11 -0400
committerLeo Famulari <leo@famulari.name>2023-07-23 22:26:01 -0400
commit25c3ad0cf6d86f7a5f7147010fef7b809ca016c7 (patch)
treef76cc781a4dee50d79233b6680b17e7deb76d892 /gnu
parent8d3217d42dbd93f1c87a2b06d57669030ba49bea (diff)
gnu: linux-libre 5.15: Update to 5.15.124.
* gnu/packages/linux.scm (linux-libre-5.15-version): Update to 5.15.124. (linux-libre-5.15-pristine-source, deblob-scripts-5.15): Update hashes. (linux-libre-5.15-source): Remove obsolete patch 'linux-libre-wireguard-postup-privkey.patch'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6ef79af6da..c76e24157c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -535,17 +535,17 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-6.1)))
-(define-public linux-libre-5.15-version "5.15.120")
+(define-public linux-libre-5.15-version "5.15.124")
(define-public linux-libre-5.15-gnu-revision "gnu")
(define deblob-scripts-5.15
(linux-libre-deblob-scripts
linux-libre-5.15-version
linux-libre-5.15-gnu-revision
- (base32 "0w5wyw8zp124nwydjvpnih7q3lp7gadlgsw60syw45nqq0afvlz3")
- (base32 "1zljgvzr8irs3acq436i2iyana9vgx4k1pm3id4rz0fbaqfma602")))
+ (base32 "18ac30kxg2mf2f6gk3p935hzhz2qs110jy4xwk21kblnnkskbxj8")
+ (base32 "03sd5z0ip16fmbgvzf69ib5iql0fsglaixcbz50jhqljv9grhacc")))
(define-public linux-libre-5.15-pristine-source
(let ((version linux-libre-5.15-version)
- (hash (base32 "1xl3nrykbxdwv5a9rk0xnb7l61dsyjvkm1ryrdii09vbmsg0i6b4")))
+ (hash (base32 "1v927z1grqwcwj6769qm14828fzjzi58lsd86al2l0ddc016l0q0")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.15)))
@@ -661,9 +661,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(define-public linux-libre-5.15-source
(source-with-patches linux-libre-5.15-pristine-source
(list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch
- (search-patch
- "linux-libre-wireguard-postup-privkey.patch"))))
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
(define-public linux-libre-5.10-source
(source-with-patches linux-libre-5.10-pristine-source