summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-08-24 02:50:49 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-08-28 20:20:16 +0200
commit279d902b591e149bf5ea2479e636c33cf3b196f7 (patch)
tree0146f8704a5a525ef2fab533843396d16fee1c76 /gnu
parent4fc36b853fb357bd5ccab0d85f29676af7aa974b (diff)
gnu: Add keyutils.
* gnu/packages/crypto.scm (keyutils): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crypto.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index b982b61dc2..73681b2c2c 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -223,3 +223,43 @@ to provide security against off-line attacks, such as a drive falling into
the wrong hands.")
(license (list license:lgpl3+ ;encfs library
license:gpl3+)))) ;command-line tools
+
+(define-public keyutils
+ (package
+ (name "keyutils")
+ (version "1.5.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://people.redhat.com/dhowells/keyutils/keyutils-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1bl3w03ygxhc0hz69klfdlwqn33jvzxl1zfl2jmnb2v85iawb8jd"))
+ (modules '((guix build utils)))
+ ;; Create relative symbolic links instead of absolute ones to /lib/*
+ (snippet '(substitute* "Makefile" (("\\$\\(LNS\\) \\$\\(LIBDIR\\)/")
+ "$(LNS) ")))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:make-flags (list "CC=gcc"
+ "RPATH=-Wl,-rpath,$(DESTDIR)$(LIBDIR)"
+ (string-append "DESTDIR="
+ (assoc-ref %outputs "out"))
+ "INCLUDEDIR=/include"
+ "LIBDIR=/lib"
+ "MANDIR=/share/man"
+ "SHAREDIR=/share/keyutils")
+ #:test-target "test"))
+ (home-page "https://people.redhat.com/dhowells/keyutils/")
+ (synopsis "Linux key managament utilities")
+ (description
+ "Keyutils is a set of utilities for managing the key retention facility in
+the Linux kernel, which can be used by file systems, block devices, and more to
+gain and retain the authorization and encryption keys required to perform
+secure operations. ")
+ (license (list license:lgpl2.1+ ; the files keyutils.*
+ license:gpl2+)))) ; the rest