summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-07-27 00:15:41 +0100
committerAndreas Enge <andreas@enge.fr>2023-08-08 09:36:59 +0200
commit296a1570926b2449c515ca3ce385103c436e058b (patch)
treeacc6dfaa9ce8cf4e59b4daa83a99eab46c5e40e2 /gnu
parentbc7a8ebcd8ea0b6d5f5da33ec62024ff55e5597b (diff)
gnu: python-pyerfa: Fix tests.
* gnu/packages/astronomy.scm (python-pyerfa): Fix tests. [build-system]: Change to pyproject-build-system. [arguments]: Disable a failing test. Add 'build-extensions phase. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 65739f6bd1..a3d71c09af 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3255,13 +3255,19 @@ exposures and high-level data products (mosaics, extracted spectra, etc.).")
;; Remove bundled submodule library.
(delete-file-recursively "liberfa")
#t))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
+ `(;; Disable only one failing test:
+ ;; AttributeError: __warningregistry__
+ #:test-flags '("-k" "not test_errwarn_reporting")
+ #:phases
(modify-phases %standard-phases
(add-before 'build 'use-system-liberfa
(lambda _
- (setenv "PYERFA_USE_SYSTEM_LIBERFA" "1"))))))
+ (setenv "PYERFA_USE_SYSTEM_LIBERFA" "1")))
+ (add-before 'check 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
(native-inputs
(list python-pytest-doctestplus python-pytest python-setuptools-scm))
(inputs