summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-08-08 10:08:19 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-08-08 10:31:10 +0200
commit29dc951b906213e7e34d238e51dce27afef0f3eb (patch)
treea3d2feb73c09bb13a5ce2674879354d3ff495474 /gnu
parentd83aa756a6ec00cadc4dda955e0c8d5a80e4fcb3 (diff)
gnu: cl-nodgui: Remove input labels.
* gnu/packages/lisp-xyz.scm (sbcl-nodgui)[inputs]: Remove labels. [arguments]: Use gexp.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm42
1 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index e956fbe5ba..b3171c6543 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11945,28 +11945,28 @@ Scalable Vector Graphics files.")
(base32 "1gsxg8igiavs8fr39vgw8ypa42wjqaq9sszwqiifpm7yvq54lls7"))))
(build-system asdf-build-system/sbcl)
(inputs
- `(("alexandria" ,sbcl-alexandria)
- ("bordeaux-threads" ,sbcl-bordeaux-threads)
- ("cl-colors2" ,sbcl-cl-colors2)
- ("cl-esrap" ,sbcl-esrap)
- ("cl-jpeg" ,sbcl-cl-jpeg)
- ("cl-ppcre-unicode" ,sbcl-cl-ppcre-unicode)
- ("cl-unicode" ,sbcl-cl-unicode)
- ("clunit2" ,sbcl-clunit2)
- ("named-readtables" ,sbcl-named-readtables)
- ("parse-number" ,sbcl-parse-number)
- ("tk" ,tk)
- ("tklib" ,tklib)))
+ (list sbcl-alexandria
+ sbcl-bordeaux-threads
+ sbcl-cl-colors2
+ sbcl-cl-jpeg
+ sbcl-cl-ppcre-unicode
+ sbcl-cl-unicode
+ sbcl-clunit2
+ sbcl-esrap
+ sbcl-named-readtables
+ sbcl-parse-number
+ tk
+ tklib))
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/wish-communication.lisp"
- (("#-freebsd \"wish\"")
- (string-append "#-freebsd \""
- (assoc-ref inputs "tk")
- "/bin/wish\"")))
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/wish-communication.lisp"
+ (("#-freebsd \"wish\"")
+ (string-append "#-freebsd \""
+ (search-input-file inputs "/bin/wish")
+ "\""))))))))
(synopsis "Common Lisp bindings for the Tk GUI toolkit")
(description
"Nodgui (@emph{No Drama GUI}) is a Common Lisp binding for the Tk GUI