summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 15:51:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:00 +0200
commit29dfa377add90ef3dc09d19fc868350e07e151bf (patch)
tree4435b8a0d9c0fe5ba7698a273a3ad1f5fb70d6b1 /gnu
parente2f661a3838413b76075f44bff3a2da08913785b (diff)
gnu: Add texlive-realscripts.
* gnu/packages/tex.scm (texlive-realscripts): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c11205e007..7235b64091 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6616,6 +6616,29 @@ The source of the filling text is the Persian epic @emph{the Shanameh} (100
paragraphs are used).")
(license license:lppl1.2+)))
+(define-public texlive-realscripts
+ (package
+ (name "texlive-realscripts")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/realscripts/"
+ "source/latex/realscripts/"
+ "tex/latex/realscripts/")
+ (base32
+ "1yk1v1ybd1zv1x6rc8qd2mbbwc5h91i44scnih6v2n5nrh61jfxb")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/realscripts")
+ (synopsis "Access OpenType subscript and superscript glyphs")
+ (description
+ "This package replaces @code{\\textsuperscript} and
+@code{\\textsubscript} commands by equivalent commands that use OpenType font
+features to access appropriate glyphs if possible. It also patches LaTeX's
+default footnote command to use this new @code{\\textsuperscript} for footnote
+symbols.")
+ (license license:lppl1.3+)))
+
(define-public texlive-refcount
(package
(name "texlive-refcount")