summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:25:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:49:33 +0200
commit2cc3983ff81f41000cc77daecfc05ab4cd9383cb (patch)
tree91acbbf79c2091ca7704f29f2a5a78454cf523c6 /gnu
parente76b90b24485029f881a2e2d3852f1d02803df58 (diff)
gnu: Add texlive-xskak.
* gnu/packages/tex.scm (texlive-xskak): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b859456c51..771c1d590a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14898,6 +14898,27 @@ to be able to create multilingual documents.")
write games or parts of games and show diagrams with special positions.")
(license license:lppl)))
+(define-public texlive-xskak
+ (package
+ (name "texlive-xskak")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xskak/" "source/latex/xskak/"
+ "tex/latex/xskak/")
+ (base32
+ "0b17y5i24adpb7f8jxf3lc5zwb1q4yf3w2vx9ql73xpi39xg6mcj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xskak")
+ (synopsis "Extension to the @code{skak} package for chess typesetting")
+ (description
+ "Xskak, as its prime function, saves information about a chess game for
+later use (e.g., to loop through a game to make an animated board). The
+package also extends the input that the parsing commands can handle and offers
+an interface to define and switch between indefinite levels of styles.")
+ (license license:lppl)))
+
(define-public texlive-xyling
(package
(name "texlive-xyling")