summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-03 12:03:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-03 12:49:34 +0200
commit2dc2c232cb9adee042b3492e89a93ff476b10309 (patch)
treea868b56ce8fcd97edef72a175cb81610eec44875 /gnu
parente6e350e6e3f3f2ca45c2f4e8fcff8f8bc05deaa3 (diff)
gnu: Add rust-cxx-test-suite-0.0.
* gnu/packages/crates-io.scm (rust-cxx-test-suite-0.0): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d7be42d7d6..8524caca11 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6370,6 +6370,26 @@ ristretto255 and Curve25519")
attributes.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-cxx-test-suite-0.0.0
+ (package
+ (name "rust-cxx-test-suite")
+ (version "0.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cxx-test-suite" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pkf4ay1210g9wqyqhkgvlcsv4i6kgdcmgnh19mrymylznv7pcal"))))
+ (build-system cargo-build-system)
+ (arguments '(#:skip-build? #t)) ; Not meant to be built independantly.
+ (home-page "https://github.com/dtolnay/cxx")
+ (synopsis "Test suite of the cxx crate")
+ (description "This package provides the test suite of the cxx crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-darling-0.10
(package
(name "rust-darling")