summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-06 18:21:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-06 23:16:55 +0300
commit3053c40995675c4b7a0c92c001e98de432326766 (patch)
treef8443ca368fb6fd3ab9a27c4d509987705702776 /gnu
parent2d5b779b451dc1f6ca244d7760287c9d5f6f2f7e (diff)
gnu: mouseloupe: Update the package style.
* gnu/packages/accessibility.scm (mouseloupe)[arguments]: Switch to g-expressions. Change-Id: I9af4433b2effbcbd9c0178ea3f02d81e202f4c05
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/accessibility.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/accessibility.scm b/gnu/packages/accessibility.scm
index 50efc48ffe..cf5a568a77 100644
--- a/gnu/packages/accessibility.scm
+++ b/gnu/packages/accessibility.scm
@@ -359,32 +359,34 @@ CONFIG_SPEAKUP_SOFT=m
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name "/" name "/v" version
"/" name "-v" version ".tar.gz"))
- (sha256 (base32 "0cvdkfakw7cix07j0c4iy10fkbqn6n8l1gr5dd3iy4f2d9bkza43"))
+ (sha256
+ (base32 "0cvdkfakw7cix07j0c4iy10fkbqn6n8l1gr5dd3iy4f2d9bkza43"))
(snippet
#~(begin (use-modules (guix build utils))
(substitute* "Makefile"
(("-D__i386__") ""))))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; there are no tests
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'strtof
- (lambda _
- (substitute* "mouseloupe.c"
- (("\\bstrtof\\b") "mouseloupe_strtof"))))
- (replace 'install
- (lambda _
- (define out (assoc-ref %outputs "out"))
- (install-file "mouseloupe" (string-append out "/bin"))
- (install-file "mouseloupe.1.gz" (string-append out "/share/man/man1")))))))
+ (list
+ #:tests? #f ; there are no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'strtof
+ (lambda _
+ (substitute* "mouseloupe.c"
+ (("\\bstrtof\\b") "mouseloupe_strtof"))))
+ (replace 'install
+ (lambda _
+ (install-file "mouseloupe" (string-append #$output "/bin"))
+ (install-file "mouseloupe.1.gz"
+ (string-append #$output "/share/man/man1")))))))
(native-inputs
- (list pkg-config))
+ (list pkg-config))
(inputs
- (list libx11 libxext libxcomposite libxdamage libxrender))
+ (list libx11 libxext libxcomposite libxdamage libxrender))
(synopsis "Screen magnifier tool for people with low vision")
- (description "MouseLoupe is a kind of magnifying glass combined with the mouse pointer
-which allows an easy and pleasant web navigation.")
+ (description "MouseLoupe is a kind of magnifying glass combined with the
+mouse pointer which allows an easy and pleasant web navigation.")
(home-page "https://sourceforge.net/projects/mouseloupe/")
(license license:gpl2+)))