summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 11:49:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:18 +0200
commit30e087c3319569409cabf2a933d4523c14d1eecd (patch)
tree05ebded2e3dc06229214cf941f60fcd4f4ddb758 /gnu
parent18b484088554389432b7b31dff4286667dac9cd9 (diff)
gnu: Add rust-rustyline-derive-0.9.
* gnu/packages/crates-io.scm (rust-rustyline-derive-0.9): New variable. (rust-rustyline-derive-0.3): Inherit from rust-rustyline-derive-0.9. Change-Id: Ie09c4331c7178e93c17d1fa45c67f390d52e6e47
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 25 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f7b6edc223..ec6e3ff4c9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -62165,28 +62165,43 @@ sub-processes using a fork-like interface.")
("rust-rustyline-derive" ,rust-rustyline-derive-0.3)
("rust-tempfile" ,rust-tempfile-3))))))
+(define-public rust-rustyline-derive-0.9
+ (package
+ (name "rust-rustyline-derive")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustyline-derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0hvaj1n0k7ys8iqfxvymmakv9aqqpvm53hagw55jw7954xaaycjs"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-2))))
+ (home-page "https://github.com/kkawakam/rustyline")
+ (synopsis "Rustyline macros implementation in Rust")
+ (description "This package provides Rustyline macros implementation in Rust.")
+ (license license:expat)))
+
(define-public rust-rustyline-derive-0.3
(package
+ (inherit rust-rustyline-derive-0.9)
(name "rust-rustyline-derive")
(version "0.3.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "rustyline-derive" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "0daj9szvfi442vj2fhm7qb92wmzv7g75qsjq9a6ycnqac4lhx9al"))))
- (build-system cargo-build-system)
+ (base32 "0daj9szvfi442vj2fhm7qb92wmzv7g75qsjq9a6ycnqac4lhx9al"))))
(arguments
`(#:cargo-inputs
(("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-1))))
- (home-page "https://github.com/kkawakam/rustyline")
- (synopsis "Rustyline macros implementation in Rust")
- (description "This package provides Rustyline macros implementation in Rust.")
- (license license:expat)))
+ ("rust-syn" ,rust-syn-1))))))
(define-public rust-rkyv-0.7
(package