summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-22 22:59:00 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-22 22:59:00 +0100
commit33a264496319a7dd0871bfc6fff6ab9aed0c66e4 (patch)
tree66e94563a3bb8e57cca884aad83b8d1a37d0edf4 /gnu
parent697252da1c7cb4eed3d50c9df0d3dc3fe368a183 (diff)
gnu: go-github-com-go-task-slim-sprig: Enable tests.
* gnu/packages/golang-xyz.scm (go-github-com-go-task-slim-sprig) [arguments] <#:tests>: Enable it. <#:phases>: Add 'remove-failing-tests phase. Change-Id: I32424925a96defd69e2871dee079db8bef2861b2
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cb8bc27021..a613287dca 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1404,9 +1404,15 @@ while callers can implement logging with whatever backend is appropriate.")
(build-system go-build-system)
(arguments
(list
- ;; Tests try to access the network.
- #:tests? #f
- #:import-path "github.com/go-task/slim-sprig"))
+ #:import-path "github.com/go-task/slim-sprig"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file
+ (string-append "src/" import-path "/network_test.go")))))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
(home-page "https://github.com/go-task/slim-sprig")
(synopsis "Various useful template functions for Go")
(description