summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:39:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:16 +0200
commit35466639a0cc4450303826f8483318c0e24719d0 (patch)
tree4cead495a6a86859119da4d3192c39a1b61d1554 /gnu
parent59b33cbe062cf774582871038f7bec7e9c7bd703 (diff)
gnu: Add texlive-linebreaker.
* gnu/packages/tex.scm (texlive-linebreaker): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 63f7f79c5a..58f4d9fd23 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16077,6 +16077,28 @@ ligature suppression rules. With the help of options and macros it can be
used for other languages as well. The package requires LuaLaTeX.")
(license license:lppl1.3c)))
+(define-public texlive-linebreaker
+ (package
+ (name "texlive-linebreaker")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/linebreaker/"
+ "tex/lualatex/linebreaker/")
+ (base32
+ "1rppq2dlj7g5djq5f0hhgk9sgk0ip1ha4vqhx6ajfpzdchg7b1cw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/linebreaker")
+ (synopsis "Prevent overflow boxes with LuaLaTeX")
+ (description
+ "This package tries to prevent overflow lines in paragraphs or boxes. It
+changes LuaTeX's @code{\\linebreak} callback and re-typesets the paragraph
+with increased values of @code{\\tolerance} and @code{\\emergencystretch}
+until the overflow no longer happens. If that doesn't help, it chooses the
+solution with the lowest badness.")
+ (license license:lppl1.3+)))
+
(define-public texlive-lineno
(package
(name "texlive-lineno")