summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-06 12:19:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-06 12:19:55 +0200
commit35f9af5f7d0d8d4252ebf46d4cec8ea75e821bda (patch)
treef9267f3db442f79c498e44a22e57740911f67c58 /gnu
parent51b25847b7bab85fde2a87d1a4eaf9fb08f1234f (diff)
gnu: emacs-websocket: Update to 1.12.
* gnu/packages/emacs-xyz.scm (emacs-websocket): Update to 1.12. [source]: Use ELPA repository instead of GitHub.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 10 insertions, 19 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6110374281..be7044de0f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11791,31 +11791,22 @@ database of references on life sciences.")
(define-public emacs-websocket
(package
(name "emacs-websocket")
- (version "1.10")
+ (version "1.12")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ahyatt/emacs-websocket.git")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "websocket-" version ".tar"))
(sha256
- (base32
- "1dgrf7na6r6mmkknphzshlbd5fnzisg0qn0j7vfpa38wgsymaq52"))))
+ (base32 "0ap4z80c6pzpb69wrx0hsvwzignxmd2b9xy974by9gf5xm2wpa8w"))))
(build-system emacs-build-system)
- (arguments
- `(#:tests? #t
- ;; TODO: also enable websocket-functional-test.el
- #:test-command '("emacs" "--batch"
- "-l" "websocket-test.el"
- "-f" "ert-run-tests-batch-and-exit")))
(home-page "https://elpa.gnu.org/packages/websocket.html")
(synopsis "Emacs WebSocket client and server")
- (description "This is an Elisp library for WebSocket clients to talk to
-WebSocket servers, and for WebSocket servers to accept connections from
-WebSocket clients. This library is designed to be used by other library
-writers, to write applications that use WebSockets, and is not useful by
-itself.")
+ (description
+ "This is an Elisp library for WebSocket clients to talk to WebSocket
+servers, and for WebSocket servers to accept connections from WebSocket
+clients. This library is designed to be used by other library writers, to
+write applications that use WebSockets, and is not useful by itself.")
(license license:gpl3+)))
(define-public emacs-oauth2