summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-01-28 13:39:51 +0800
committerHilton Chain <hako@ultrarare.space>2024-02-05 14:04:32 +0800
commit368c6e3cf07a12c190bc6ebc713f9bb7f99ee9fd (patch)
tree8335c9e634a28560b99c0d91637f7b777fdc7923 /gnu
parentb896b9102b83e6e29eec95c488ff73abe8c7ca3d (diff)
gnu: Add pam-uaccess.
* gnu/packages/admin.scm (pam-uaccess): New variable. Change-Id: I71b16e8548359fe59b2d09bb91b050bf9be33a78
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index fcf05992d8..2dbb604fa9 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4907,6 +4907,33 @@ It can mount all local file systems supported by @command{mount}, as well as
LUKS volumes encrypted with the user's log-in password.")
(license (list license:gpl2+ license:lgpl2.1+))))
+(define-public pam-uaccess
+ (let ((commit "54fbf043c63cc500b4850b0b4a12ea14078f2b53")
+ (revision "0"))
+ (package
+ (name "pam-uaccess")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~kennylevinsen/pam_uaccess")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08068cw4nvcanym8b5dyccnnb3qc3f09pbvi6fcfiz227yx73npc"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list acl eudev linux-pam))
+ (home-page "https://git.sr.ht/~kennylevinsen/pam_uaccess")
+ (synopsis
+ "PAM module that grants access to devices tagged @code{uaccess} in udev")
+ (description
+ "@code{pam_uaccess} is a PAM module that grants access to devices tagged
+@code{uaccess} in udev for the duration of the users' session, replacing
+elogind's uaccess feature.")
+ (license license:expat))))
+
(define-public jc
(package
(name "jc")