summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-02 20:30:17 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-04-04 09:38:41 +0200
commit3905bd72996578a83dcc5aa40c0bdcee1cd08cc6 (patch)
tree19ec1305278f96c6467acc7327dabe4cb75292a0 /gnu
parent8f4b37ee7d848df853078af6d9cea46b24be5b4f (diff)
gnu: Add cl-fast-ecs.
* gnu/packages/lisp-xyz.scm (cl-fast-ecs, ecl-cl-fast-ecs, sbcl-cl-fast-ecs): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a365dd7954..357c2ba937 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6962,6 +6962,43 @@ mostly Common Lisp implementation.")
(define-public ecl-cl-fastcgi
(sbcl-package->ecl-package sbcl-cl-fastcgi))
+(define-public sbcl-cl-fast-ecs
+ (package
+ (name "sbcl-cl-fast-ecs")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/lockie/cl-fast-ecs")
+ (commit version)))
+ (file-name (git-file-name "cl-fast-ecs" version))
+ (sha256
+ (base32 "06cnhm8zpyqyjr17mji5wvj4gh2glpdw8gqy1vwrq3vgphfmg560"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-parachute))
+ (inputs
+ (list sbcl-alexandria sbcl-trivial-garbage))
+ (home-page "https://lockie.gitlab.io/cl-fast-ecs/")
+ (synopsis "Blazingly fast Entity-Component-System microframework")
+ (description
+ "CL-FAST-ECS is a Common Lisp library providing an implementation of the
+@acronym{ECS, Entity-Component-System} pattern, primarily focused on speed and
+interactive development.
+
+ECS is an architectural data-oriented design pattern that allows for the
+effective processing of a large number of in-game objects while keeping the code
+and data separated. This provides flexibility in the way that game objects are
+built at runtime.")
+ (license license:expat)))
+
+(define-public cl-fast-ecs
+ (sbcl-package->cl-source-package sbcl-cl-fast-ecs))
+
+(define-public ecl-cl-fast-ecs
+ (sbcl-package->ecl-package sbcl-cl-fast-ecs))
+
(define-public sbcl-cl-flac
(let ((commit "d094d33d3cc2cf263263b917798d338eded3c532")
(revision "0"))