summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-10-27 09:18:53 +0400
committerAndrew Tropin <andrew@trop.in>2022-10-27 09:18:53 +0400
commit39dfa2947f765c32148e7ac8cba4e6199a815b5f (patch)
treedfdc5cd35e3ed1c9d36a74479abb5ebb69ae7a9c /gnu
parent5dda4c69f075dcee020e51f4559cb3df4d2336c4 (diff)
gnu: Add emacs-inflections.
* gnu/packages/emacs-xyz.scm (emacs-inflections): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 35b3bad33e..aefa5108fd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4594,6 +4594,27 @@ which is restored where possible when the file is loaded again.")
strings.")
(license license:gpl3+)))
+(define-public emacs-inflections
+ (package
+ (name "emacs-inflections")
+ (version "2.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eschulte/jump.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (snippet #~(begin (delete-file "jump.el")))
+ (sha256
+ (base32 "03fh7i6blnbc0zbmp83fk095hr3q4fdvrvfxad74zghcbc2nk7b7"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/eschulte/jump.el")
+ (synopsis "Convert english words between singular and plural")
+ (description "This package provides an Emacs library for converting
+english words between singular and plural.")
+ (license license:gpl3+)))
+
(define-public emacs-blight
(let ((commit "6bf9c6192d2bf979eebbfae1963401ef3ff4ef5d")
(revision "0"))