summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-01-09 22:18:06 +1000
committerBen Woodcroft <donttrustben@gmail.com>2018-01-09 22:39:05 +1000
commit39fb853abe060973c0ca6f8b60a105b1a83e583b (patch)
tree8fa831a90d2bfb9beb617b49eb7ef10f1568e21a /gnu
parent5424f9bcab01d7017550d79cdf42daea87151da0 (diff)
gnu: seqmagick: Update to 0.7.0.
* gnu/packages/bioinformatics.scm (seqmagick): Update to 0.7.0. Use python-3. [arguments]: Remove replacement phase for check. [inputs]: Add biopython. Remove python2-biopython-1.66. (python2-biopython-1.66): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm35
1 files changed, 4 insertions, 31 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ce66ce0d37..34b843cfbb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -790,20 +790,6 @@ into separate processes; and more.")
(define-public python2-biopython
(package-with-python2 python-biopython))
-;; An outdated version of biopython is required for seqmagick, see
-;; https://github.com/fhcrc/seqmagick/issues/59
-;; When that issue has been resolved this package should be removed.
-(define python2-biopython-1.66
- (package
- (inherit python2-biopython)
- (version "1.66")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "biopython" version))
- (sha256
- (base32
- "1gdv92593klimg22icf5j9by7xiq86jnwzkpz4abaa05ylkdf6hp"))))))
-
(define-public bpp-core
;; The last release was in 2014 and the recommended way to install from source
;; is to clone the git repository, so we do this.
@@ -5391,7 +5377,7 @@ bioinformatics file formats, sequence alignment, and more.")
(define-public seqmagick
(package
(name "seqmagick")
- (version "0.6.1")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
@@ -5400,25 +5386,12 @@ bioinformatics file formats, sequence alignment, and more.")
version ".tar.gz"))
(sha256
(base32
- "0cgn477n74gsl4qdaakrrhi953kcsd4q3ivk2lr18x74s3g4ma1d"))))
+ "12bfyp8nqi0hd36rmj450aygafp01qy3hkbvlwn3bk39pyjjkgg5"))))
(build-system python-build-system)
- (arguments
- ;; python2 only, see https://github.com/fhcrc/seqmagick/issues/56
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- ;; Current test in setup.py does not work as of 0.6.1,
- ;; so use nose to run tests instead for now. See
- ;; https://github.com/fhcrc/seqmagick/issues/55
- (replace 'check (lambda _ (zero? (system* "nosetests")))))))
(inputs
- ;; biopython-1.66 is required due to
- ;; https://github.com/fhcrc/seqmagick/issues/59
- ;; When that issue is resolved the 'python2-biopython-1.66' package
- ;; should be removed.
- `(("python-biopython" ,python2-biopython-1.66)))
+ `(("python-biopython" ,python-biopython)))
(native-inputs
- `(("python-nose" ,python2-nose)))
+ `(("python-nose" ,python-nose)))
(home-page "https://github.com/fhcrc/seqmagick")
(synopsis "Tools for converting and modifying sequence files")
(description